Outlook Problems...

Geoff S geoff.s at emypeople.net
Tue Sep 22 22:13:06 CEST 2020


System: CentOS 8 (selinux disabled for now)

While I appreciate the work that's obviously gone into Automx2, I've had 
a difficult time reaping the benefits. I'm wondering...does anyone know 
what versions of Outlook are supposed work with Automx2? I am mostly 
stuck with "testconnectivity.microsoft.com", which as others have said, 
sends requests to "/Autodiscover/Autodiscover.xml'. It's trivial to 
redirect/return/rewrite with NGINX, but no matter how it's done, there 
are apparently problems with the POST-ed xml that's passed through any 
kind of redirect.

My current conf snippet (I know "IF is evil", but once i find something 
that works, I'll work on security!):

|        ...

|        ## Rewrite URI if the path contains uppercase characters.
         ## (Uses perl module & function defined in nginx.conf):
         location ~ [A-Z] {
             if ($request_method = POST ) {
                 return 307 $scheme://$host$uri_lowercase;
             if ($request_method = GET ) {
                 return 301 $scheme://$host$uri_lowercase;

|        ...|

The bigger problem is that whenever a request comes from Outlook (we 
just now tried 2016), or generated by a cURL call to Microsoft api 
it's getting a '400'. (No caps in these requests, so unaffected by the 
above issue)  If I submit a cURL request directly, it works perfectly 
(caps or lc), but no actual MS products seem to get it!

I have also used 'automx2_discover' for testing, with the same result. 
Works fine (returns MS & Mozilla configs , haven't tried Apple), but...?

Here are a few log lines from flask.sh on a failed attempt (automx2 runs 
as a systemd unit):

Sep 22 15:06:27 mail.obfuscate.com flask.sh[20797]: - - 
[22/Sep/2020 15:06:27] "GET 
HTTP/1.0" 404 -
Sep 22 15:06:27 mail.obfuscate.com flask.sh[20797]: Missing request 
argument "EMailAddress"
Sep 22 15:06:27 mail.obfuscate.com flask.sh[20797]: - - 
[22/Sep/2020 15:06:27] "POST /autodiscover/autodiscover.xml HTTP/1.0" 400 -
It seems to be much the same problem described previously here 
<https://mail.sys4.de/pipermail/automx-users/2020-April/000239.html> by 
Eric Duval. Seems he solved it, but unfortunately shared no details. 
What can I try, or what other info might be helpful?|

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mail.sys4.de/pipermail/automx-users/attachments/20200922/627bca96/attachment-0001.html>

More information about the automx-users mailing list