database setup

David Mehler dave.mehler at
Sun Apr 5 16:18:18 CEST 2020


I've added my specific information to the user-generated section of
the script. If I run it with ./
it runs, dumps the output to the screen with no syntax errors. If I

./ | sqlite3 /var/db/automx2/db.sqlite

this is what I get:

Error: near line 1: no such table: provider
Error: near line 2: no such table: server
Error: near line 4: no such table: server
Error: near line 6: no such table: domain
Error: near line 7: no such table: server_domain
Error: near line 8: no such table: server_domain

If you've got this working what did you do?


On 4/5/20, William Edwards <wedwards at> wrote:
>> Op 5 apr. 2020 om 03:39 heeft David Mehler <dave.mehler at> het
>> volgende geschreven:
>> Hello,
>> Trying to insert commands in to the sqlite3 database, and keep getting
>> the error no table named domain or servers exist, no table definitions
>> defined. I created per the installation docs, if I
>> run the script from the commandline without piping it through sqlite3
>> it works fine, but when going through sqlite3 that's when I get the
>> errors.
> “The errors”?
>> as the automx2 user with the python3 virtual environment activated I run:
>> | sqlite3 /var/db/automx2/db.sqlite
>> Suggestions welcome.
>> Thanks.
>> Dave.

More information about the automx-users mailing list